China Car Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi guys. I am facing major issues with my H5 the van starts up nicely. Once I start driving the EBD light and ABS light up aswell as engine light flushing plus the spanner light. Before I drive any further the vehicle cuts out. I have done fuel pump. Coil. Diagnostics brought up o2 sensor bank 2 and stil after replacing back to the old issues. So frastrated and exhausted. From live data all speed sensors are working. Someone please help. Regards
 

·
Registered
Joined
·
445 Posts
Hi Gilbert,
So far I'm not seeing any response to your call for help. I wonder if that is because you haven't clearly identified the problem vehicle. You say it's an "H5 van" but nothing else. You don't give the manufacturer name, the model, or year, or other pertinent info. Great Wall produces a Haval H5, but its an SUV. Chery produced an H5 van back in around 2011. FAW also produces an H5, but it's a Honqi sedan not a van. Higer Bus produces a small RV van called H5-V.
So give us some more info, and some kind tech out there may have a remedy for you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi Gilbert,
So far I'm not seeing any response to your call for help. I wonder if that is because you haven't clearly identified the problem vehicle. You say it's an "H5 van" but nothing else. You don't give the manufacturer name, the model, or year, or other pertinent info. Great Wall produces a Haval H5, but its an SUV. Chery produced an H5 van back in around 2011. FAW also produces an H5, but it's a Honqi sedan not a van. Higer Bus produces a small RV van called H5-V.
So give us some more info, and some kind tech out there may have a remedy for you.
Hi it's a Gwm hoover 5.SUV.with a delfi ecu
 
1 - 3 of 3 Posts
Top