China Car Forums banner

Suda SA01 fast charging doesn't work in Lithuania's stations

1056 Views 0 Replies 1 Participant Last post by  Garuniks

I bought Suda SA01. But fast charging doesn't seem to work on most of the charging stations in Vilnius, Lithuania.

From all the the stations that I have tried, it worked only on one type of charging station. This is the charging station that it worked on. It's 320kW and around 1000V station I think. And the charging power that I got for Suda SA01 was around 22kW.

Car Vehicle Plant Wheel Motor vehicle

Other stations that don't support Suda SA01 fast charging are probably 500V, that might be the reason why it doesn't work. It starts charging, but error says that car stopped the charging after 5-10 seconds of charging.

Why do you think fast charging doesn't work for Suda SA01 in charging stations that are in Vilnius, Lithuania?
See less See more
1 - 1 of 1 Posts
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.